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Overview 
D-Case Editor is implemented as an Eclipse plug-in. This means D-Case Editor realizes the 

features of the diagram editing with Eclipse basic feature. 

Many features can be used same as Eclipse’s features. If you want to use D-Case Editor, you 
should know Eclipse’s basic concept and workflow. 

This document describes the features about D-Case Editor. If you need to know Eclipse’s basic 
features, show other documents about Eclipse.  

D-Case Editor uses Eclipse’s file management features as the diagram files monument. And 
editor uses workspace, project, folders which are provided by Eclipse’s features 
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1. Preferences 
1 . 1 .  Preferences 
 

Set some configurations in “Window” >“Preferences” >“D-Case Diagram”. 

 

Parameters 
 

In the section, you can define parameters which can be used at D-Case diagram. 

The parameters which can be defined are below. 

Table 1 type of parameters 

type attribute 

string min：minimum of string length 
max：maximum of string length 

raw min：minimum of string length 
max：maximum of string length 

int min：lower bound 
max: upper bound 

double min：lower bound 

max: upper bound 

digit: the number of decimal places 

inc: the unit of increment. 

enum items: the list of enumerated items 
 

The characters below can’t be used as parameter name. 

, ; { } ＝ 

 

The terms below can’t be used as parameter name  because of reserved words. 

Id 

Requirements  

n  

The characters below can’t be used as item name of enum. 

, ; { } 

 

Parameter definitions 

Parameter definitions can be import / export as XML files.  

Parameters already defined aren’t deleted when importing another xml file. If same parameter 
already defined, it is overwritten. 

If parameter name in an xml file is reserved word, it is not imported.
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Bookmarks 
In the section, you can register a URL and bookmark name which can be used in D-Case diagram. 

 

Converters 
In the section, you can register XSL files and converter names. 
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2. Creating and Saving a Diagram 
2 . 1 .  Creating a New Diagram 
Creating a New Diagram 
To create a new D-Case diagram, follow the procedure below and generate a new diagram in 
the project folder. 

New Diagram Creation Flow 

Table 2 New Diagram Creation Flow 

No. Procedure Behavior Details 
1 Select “New” > “Other…” 

from the File menu of 
eclipse 

A new wizard is displayed.  Wizard is activated.  

2 Select “D-Case Diagram” 
in the “D-Case Editor” 
category and click the 
“Next” button.  

“D-Case Diagram” is selected. 
Page transition.  

Enter the required information in the 
wizard.  
Select to create a new “D-Case 
Diagram” from the menu. 

3 Select the folder to store 
the new diagram.  

The name of the selected folder 
is displayed in the text box of 
the parent folder.  

Enter the required information in the 
wizard. 
Select the folder to store the diagram 
from the wizard tree.  

4 Enter the name of the 
GMF diagram information 
file of the diagram to be 
created and click the 
“Next” button.  

Page transition.  Enter the required information in the 
wizard. 
A D-Case diagram consists of a 
diagram file and a model information 
file. Enter the name of the diagram file 
first.  

5 Enter the name of the 
GMF model information 
file of the diagram to be 
created and click the 
“Finish” button.  

A new diagram is created and 
the editor window opens.  

When the name of the GMF model 
information file is entered, a D-Case 
diagram (diagram, model) will be 
generated and displayed in the editor 
window.  

 

2 . 2 .  Opening a Diagram 
Double click the D-Case GMF diagram information file that is displayed in the project explorer to 
open a diagram in the editing window. The diagram can then be edited. 

2 . 3 .  Saving a Diagram 
To save a file, select one of the following items in the “File” menu.  

1. “Save” item 
The contents of the selected editing window will be saved in the model information file and 
the diagram information file.  

2. “Save As...” item 
The contents of the selected editing window will be saved in the model information file and 
the diagram information file with a different name.  

3. “Save All” item 
The contents of all editing windows will be saved in the corresponding model information 
files and the diagram information files.  

 
 
 

2 . 4 .  Renaming a Diagram (Rename) 
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The name of the diagram file and the model information file will be changed at the same time to 
the specified name when a diagram is renamed.  

The files of the diagrams that are being displayed cannot be renamed.  

The diagram file and the model information file will have the same name after renaming 
(extensions are different).  

 

File Renaming Flow 

Table 3 File Renaming Flow 

No. Procedure Behavior Details 
1 Select a diagram file in Package Explorer.   

2 Select”D-Case”>”File”>”Rename...” from 
the menu bar.  

Dialog for entering the file name is 
displayed.  

 

3 Enter a new file name.    

3.1 Click the “OK” button.  File name dialog closes.  
The name of the diagram file and 
the model information file is 
changed to the new file name.  

 

3.2 Click the “Cancel” button.  File name dialog closes.   

 

2 . 5 .  Copying a Diagram (Copy To) 
 

Diagram file and model information file will be copied at the same time when a diagram is 
copied.  

The copied diagram file and model information file will have the same file name (with different 
extensions).  

 

File Copying Flow 

Table 4 File Copying Flow 

No. Procedure Behavior Details 
1 Select a diagram file in Package 

Explorer. 
  

2 Select”D-Case”>”File”>”Copy To...” 
from the menu bar.  

Dialog for entering the file name is 
displayed. 

 

3 Enter a new file name.    

3.1 Click the “OK” button.  File name dialog closes. 
The copied diagram file and model 
information file will have the specified 
file name.  

 

3.2 Click the “Cancel” button.  File name dialog closes.  

 

3. Editing Function 
3 . 1 .  Editing a Diagram 
Selecting an Element from Palette 
Nodes and links selected from Palette can be added to the canvas.  
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Figure 1 Elements Menu in Palette 

The following elements are available in Palette.  

Table 5 Elements in Palette 

category element note 

GSN Nodes 

Goal  

Evidence  

Strategy  

Context  

Justification  

Assumption  

Undeveloped  

Module It doesn’t conform to GSN standard. 

Contract It doesn’t conform to GSN standard 

D-Case Nodes 

Monitor  

System  

Policy  

Userdef001  

Userdef002  

Userdef003  

Links 

Supported By Solid line with arrow. 

In Context Of Solid line with arrow(outlined) 

Link Solid line 

Link Dotted line 
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Node Addition Flow 

Table 6 Node Addition Flow 

No. Procedure Behavior Details 

1 Click a given node in 
Palette.  

The clicked node becomes selected.   

2 Click a spot in canvas to 
place the node.  

The node is added to the canvas at the 
specified position. 

 

    

 

Link Connection Flow 

Table 7 Link Connection Flow 

No. Procedure Behavior Details 
1 Click a link in Palette.  The clicked link becomes selected.   

2 Click a node and drag and 
drop it to another node.  

The first node is connected to the 
second node by a link.  

 

    

 

Selecting a Node in the Popup Menu 
Popup menu opens when the mouse cursor is placed in the graphic-object editing area and is 
kept still for a moment. A node can be created by selecting the corresponding icon in the menu. 

 

Figure 2 Popup Menu 

Creating a Link with “Arrow with Square” 
A link can be created by dragging the square part of the link icon displayed outside the border of 
a node and connecting it to another node. 

Figure 3 Arrow with Square 

 

Copying and Pasting an Element 
Elements in a diagram can be copied and pasted. 

To copy an element, select the element and click “Copy” in the “Edit” menu. The copied element 
can be pasted by clicking “Paste” in the “Edit” menu without selecting any element.  
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Changing the Attributes 
To edit the node attributes, click to select an item and perform either of the following.  

1. Click to edit the characters that are displayed.  
2. Change the attribute value displayed in “Properties View.”  
3. Select the menu bar button and change the attributes.  

 
When “Properties View” is not displayed, right click the graphic-object editing area and 
select ”Show Properties View” to display “Properties View.”  

 

Changing the Attribute in the Attribute Input Dialog 
Attribute can be set in the attribute input dialog.  

Attribute Input Flow 

Table 8 Attribute Input Flow 

No. Procedure Behavior Details 
1 Select a node in 

diagram.  
  

2 Double click the 
node or click the 
“Enter” key.  

Attribute input dialog is displayed.   

3 Enter the 
attribute. 

  

4.1 Click the “OK” 
button.  

Attribute input dialog is closed and the 
attribute is updated.  

 

4.2 Click the “Cancel” 
button.  

Attribute input dialog is closed.   

 

 

Deleting a Node or a Link 
To delete a node or a link, click to select the node/link and perform either of the following.  

1. Press the “BS” key.  

2. Press the “Delete” key.  
3. Select “Delete” from the “Edit” menu.  
4. Right click the item and select “Delete from Model” from the context menu.  
 

※Argument can be deleted. But child elements are also deleted and the argument cannot 
be edited ever.  

 

3 . 2 .  Editing a Diagram Using Templates 
Displaying the Template View 
A template project must be prepared in advance in the work space same as the D-Case project.  

- The structure of the template project is independent from the D-Case Editor plug-in and 
can be changed at a given timing. However, the template view must be closed and opened 
again for the latest changes to be reflected.  
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Template View Display Flow 

Table 9 Template View Display Flow 

No. Procedure Behavior Details 
1 Display the “Show 

View” dialog. 
The “Show View” dialog is displayed.  Select”Window” > “Show View” > 

“Other” from the menu.  
 

2 Select the 
template view.  

”Templateｓ  View” becomes selected.  Select “Templates” from the “D-Case 
Editor” category.  

3 Click the “OK” 
button.  

Template view is displayed.   
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Creating a New Template Diagram 
Create a project folder for storing the template before creating a new template D-Case diagram 

New Template Diagram Creation Flow 

Table 10 New Template Diagram Creation Flow 

No. Procedure Behavior Details 
1 Select “New” > “Other…” 

from the “File” menu of 
eclipse.  

A new wizard is displayed.  Wizard is activated.  

2 Select “D-Case Diagram” 
in the “D-Case Editor” 
category and click the 
“Next” button. 

“D-Case Diagram” is selected. 
Page transition.  

Enter the required information in the 
wizard.  
Select to create a new “D-Case 
Diagram” from the menu. 

3 Select a given folder in 
the D-Case Template 
project to store the 
new template diagram.  

The name of the selected folder 
is displayed in the text box of 
parent folder.  

Enter the required information in the 
wizard. 
D-Case Template folder needs to be 
created in advance.  

4 Enter the name of the 
GMF diagram information 
file of the diagram to be 
created and click the 
“Next” button.  

Page transition.  Enter the required information in the 
wizard. 
A D-Case diagram consists of a 
diagram file and a model information 
file. Enter the name of the diagram file 
first. 

5 Enter the name of the 
GMF model information 
file of the diagram to be 
created and click the 
“Finish” button. 

A new diagram is created and 
the editor window opens.  

When the name of the GMF model 
information file is entered, a D-Case 
diagram (diagram, model) is generated 
and displayed in the editor window. 

 

 

Editing a Template Diagram 
 

Template Editing Flow 

Table 11 Template Editing Flow 

No. Procedure Behavior Details 
1 Open a template 

diagram.  
Template diagram is displayed.  Open a template diagram that is already 

created.  
Same as when creating a normal 
D-Case diagram.  

2 Add, edit, or 
delete the 
elements.  

Diagram is changed.  Same as editing a normal D-Case 
diagram.  

3 Save the changes.  Diagram information file and GMF 
model information file are saved.  

GMF model information file will be used 
as the template.  

 

 

Adding Elements from Template to Diagram 
To add elements from template to diagram, follow the procedure below.  

- Element(s) to be added from template is/are selected.  
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- Element(s) to be added from template is/are to be placed around the middle of the diagram. 
(Position cannot be specified when adding the element[s].)  

 

Template Addition Flow 

Table 12 Template Addition Flow  

No. Procedure Behavior Details 
1 Activate the 

diagram to add a 
template to.  

The target diagram becomes active.  Perform either of the following.  
– Create a new D-Case diagram.  
– Open an existing D-Case diagram.  
– Activate a non-active diagram.  
When creating a new diagram or 
opening an existing diagram, click the 
canvas of the diagram once.  
When there is no active D-Case Editor, 
an error message will be displayed.  

2 Select a template. Template becomes selected in the 
template view.  

Expand the tree structure and click to 
select a pattern or a library.  
Only one template can be selected at a 
time.  
Template will not become selected 
when only a folder under the tree 
structure is selected.  

3 Add the template.  Template is added and the elements 
are automatically arranged in the 
diagram.  
The added element(s) is/are selected. 
File is updated and the “*” mark is 
displayed.  
When a node with parameters is 
included in the template, the parameter 
value input dialog will be displayed. 
When the parameter values are 
entered, the template will be added to 
the diagram.  

Click the icon (plus symbol) of the tool 
bar in the template view.  
Alternatively, select “Add Template” 
from the pull-down menu of the 
template view.  

 

 

 Adding Element(s) to Diagram from Template View 
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Figure 4 Adding Element(s) to Diagram from Template View 
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3 . 3 .  Setting an Attachment File 
Every node can be set attachments. 

Attachment 

You can select attachment files from the places below. 

・Workspace 

・Web 

 

・Selection from Workspace 
Display the context menu of a node or a canvas. 

And select  “Attachment” > “Select from Ｗworkspace”. 

 

・Selection from Web 
Display the context menu of a node or a canvas. 

And select “Attachment” > “Select from Web”. 

In Web browser dialog, you can select urls which is set as bookmarks 

サブツリーの一括選択  
選択したノードから連なるノードを全て選択状態にする。 

1. 特定のノードを選択して右クリックし、コンテキストメニューを表示する。 

2. メニューから”Select subtree”を選択する。 
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3 . 4 .  Parameters  
Parameters can be set in node.  

The parameter settings can be used for formatting the character string of Desc and generating 
scripts.  

 

Configuring Parameters 
The parameters can be set to each node and argument. The parameters set to an argument can 
be referred as “global parameters” from all nodes in the argument.  

 

Parameters Configuration Flow 

Table 13 Parameters Configuration Flow  

No. Procedure Behavior Details 
1 Select an node or a diagram and right 

click 
Context menu is displayed.   

2 Select “Ｐａｒａｍｅｔｅｒｓ”＞”Configure 

Parameters” in the context menu. 
Configure Parameters dialog is displayed.   

3 Configure the parameters.    

4.1 Click the “OK” button.  Configure Parameters dialog is closed and the 
parameters configuration is updated.  

 

4.2 Click the “Cancel” buttons.  Configure Parameters dialog is closed.   
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Configure Parameters Dialog 

 

 

Figure 5 Configure Parameters Dialog 

 

Setting Parameter Values 
 

For nodes with parameters, the parameter values can be set according to the parameter 
configuration.  

Global parameters can be changed in an argument. 

 

 

Table 14 Attributes of Goal Node  

Attribute Value Settings Example 

Userdef005 Formatted 
character 
string for 
Desc 

Combination of
｛parameter name｝and 
character string.  

Input example: CPU usage is {CPU} or lower.  

Desc display example: CPU usage is 60 or 
lower.  

Userdef006 Script Combination of 

｛parameter name｝ and 

character string 

 

Userdef007 Parameter When there are multiple 
sets of Parameter name 
= Parameter value, 
each set is separated 
from the next one by a 

Input example: CPU=60 
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Attribute Value Settings Example 
comma. 

Values can be entered 
in the attributes set to 
parameters. These 
attributes can also be 
used in the formatted 
character strings for 
Desc.  

“id” is a reserved word 
indicating the node id. 
Therefore, it cannot be 
used as a parameter.  

 

 

 

Parameter Values Setting Flow 

Table 15 Parameter Values Setting Flow 

No. Procedure Behavior Details 
1 Select a node or a canvas which has 

parameters and right click. 
Context menu is displayed.   

2 Select”Parameters”>”Set 

Parameters” in the context 

menu. 

Set Parameters dialog is displayed.   

3 Set the parameters.    

4.1 Click the “OK” button.  Set Parameters dialog is closed and the 
parameter values are updated.  
Desc is updated according to the formatted 
character string and parameter values.  
If global parameters are set, it updates the nodes 

which use these parameters. 

 

4.2 Click the “Cancel” buttons.  Set Parameters dialog is closed.   

 

Set Parameters Dialog 

 

 

Figure 6 Set Parameters Dialog 
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3 . 5 .  Performing Validation 
- Links between nodes are checked.  

- The attribute values of nodes and links are checked.  

- Cycle structure of the entire diagram or a part of the diagram is checked.  

- Detectable errors are all detected and the markers indicating the places where the errors 
occurred are displayed along with the description of the errors in the view of eclipse.  

- The displayed markers will be cleared when Validation is performed again.  

 Performing Validation 

 

 

Figure 7 Performing Validation 
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Results of Validation  

 

 

- The items to be checked by the Validation function can be selected from Preferences.  

Validation Function Settings 

Figure 8 Results of Validation 

Figure 9 Validation Function Settings in the Preferences Dialog 
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Validation rules. 

 

Multiplicity between nodes 

  Target 

 	  

Goal , 

System 

Undevelope

d Strategy Evidence Monitor Context 

Justif icatio

n other 

Source Goal , 

System - 1..* ： 0..1 1..* ： 0..1 1..* ： 0..1 1..* ： 0..1 0..1 ： 0..* 1 ： 0..* 0..* ： 0..* 

Undeveloped - - - - - - - 0..* ： 0..* 

Strategy 1..* ： 1..* - - - - 0..1 ： 0..* - 0..* ： 0..* 

Evidence - - - - - 0..1 ： 0..* - 0..* ： 0..* 

Monitor - - - - - 0..1 ： 0..* - 0..* ： 0..* 

Context - - - - - - - 0..* ： 0..* 

Justif ication - - - - - - - 0..* ： 0..* 

other 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 0..* ： 0..* 

 

Table 16 multiplicity between nodes 
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There are some restrictions in connection from goal. 

・	 Goal cannot connect to Undeveloped, Strategy, Evidence, Monitor in the same time. 

・	 Justification cannot connect to Goal which connects to Evidence or Monitor. 

There are also restrictions in connection from Context. 

・	 A Context can connect to just one Goal or Strategy or Evidence or Monitor.  

 

The table below shows connection rules from Goal and System. Goal 

condit ion 

to Strategy Y Y Y Y Ｎ - - Ｎ - - Ｎ - Ｎ 

to Undeveloped Ｎ Y - - Y Y Y Ｎ - - Ｎ - - 

to Evidence Ｎ - Y - Ｎ Y - Y Y Y Ｎ - Ｎ 

to Monitor Ｎ - - Y Ｎ - Y Ｎ Y - Y Y Ｎ 

to Context - - - - - - - - - - - - - 

to Justif ication - - - - Ｎ - - Ｎ - Y Ｎ Y - 

behavior Val idation error occurs Ｎ Ｙ Ｙ Ｙ Ｎ Ｙ Ｙ Ｎ Ｙ Ｙ Ｎ Ｙ Ｎ 

Table 17 Rules of connection from goal 

 

The table below shows connection rules to Context. 

condit ion 

from Goal , System Y Y Y Y Ｎ - - Ｎ - Ｎ 

from Strategy Ｎ Y - - Y Y Y Ｎ - Ｎ 

from Evidence Ｎ - Y - Ｎ Y - Y Y Ｎ 

from Monitor Ｎ - - Y Ｎ - Y Ｎ Y Y 

動作 Validation error occurs Ｎ Ｙ Ｙ Ｙ Ｎ Ｙ Ｙ Ｎ Ｙ Ｎ 

Table 18 Rules of connection to Context 

 

Valid node attribute value 

The value of attribute “weight” of  Goal/System must be greater than 1.
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3 . 6 .  Calculating the Score 
The score of Goal is calculated based on the connection status and importance of Evidence to 
measure the dependability.  

・Goals that have sub goals  the sum of (score * weight) / the sum of the weight of sub goal  

・Goals that don’t have sub goals  1 if evidences exist Evidence, 0 else. 

- For score calculation, the System node is treated as equivalent to the Goal node.  

- For score calculation, the Monitor node is treated as equivalent to the Evidence node.  

- Calculated results will be set in the Score property.  

- The scores of all Goal and System nodes are initialized at calculation. Initial value is 0.  

 

The table below shows the rules of calculation of the score. 

 

condit io

n 

connected Strategy from Goal、System - - - Y Y Y Ｎ N 

connected Evidence from Goal , System  - - - N Y - Ｙ N 

connected Undeveloped from Goal , System - - - N - Y - - 

Connected Strategies from Goal , System Y - - N N N Ｎ N 

The weight is not integer greater than 1 - Y - N N N Ｎ N 

The connection is loop - - Y N N N Ｎ N 

behavior 
The score 0 0 null ＊1 0 0 1 0 

Val idation error occurs Y Y Ｎ N Y Y Ｎ N 

Table 19 the calculation of the score 

＊1  the sum of (score * weight) / the sum of the weight of sub goal. If no sub goal, then 0. 

Sub goal is the Goal or the System which are connected Goal or System through Strategy. 

The pattern which doesn’t exist at the table isn’t processed. 

 

 

Score Calculation Flow 

Table 20 Score Calculation Flow 

No. Procedure Behavior Details 
1 Right click on 

canvas to open 
the popup menu.  

Popup menu is displayed.   

2 Select 
“Calculate the 
Score.” 

The score of each Goal is calculated 
and the results will be displayed in 
Score.  

 

 

Performing Score Calculation 
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Figure 10 Performing Score Calculation  
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3 . 7 .  Autocomplete 
This function provides a list of child nodes that can be connected to a given node for the user to 
select from.  

Child nodes are to be selected from new nodes or templates.  

 

Adding a New Node 
Nodes that can be connected to the selected node as its child nodes are displayed. 

 
Node Addition Flow 

Table 21 Node Addition Flow 

No. Procedure Behavior Details 

1 Right click a given node in Palette. Context menu is displayed.   

2 Select “Add Child” >”Create a 
New Node” from the context 
menu.  

A list of the nodes that can be 
added is displayed in the context 
menu.  

 

3 Select the node to be added.  A new node is added and 
connected to the selected node. 
(Link is connected from the 
selected node to the added node.  

 

 

 

Adding from Templates 
Templates that are associated with the selected node by definition file are displayed.  

 

Adding from Templates Flow 

Table 22 Adding from Templates Flow 

No. Procedure Behavior Details 

1 Right click a given node in Palette. Context menu is displayed.   

2 Select “Add Child” >”Add a 
Template” from the context 
menu.  

A list of the templates associated 
with the node by definition file is 
displayed in the context menu.  

 

3 Select the template to be added.  Template is added.   
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Associating Templates with Nodes 
Nodes and Templates are associated with each other by the definition file.  

Diagrams that satisfy the following condition can be included in the autocomplete list.  

Node type 

One of the keywords (comma, period, space) included in the Desc attribute of node corresponds 
to tag.  

The schema of definition file is shown below.  

 
<?xml version="1.0" encoding="utf-8"?> 
<xs:schema 
targetNamespace="http://www.dependable-os.net/2010/09/dcase/complement" 
elementFormDefault="qualified" 
xmlns="http://www.dependable-os.net/2010/09/dcase/complement" 
xmlns:mstns="http://www.dependable-os.net/2010/06/dcase/complement" 
xmlns:xs="http://www.w3.org/2001/XMLSchema" version="0.3.0"> 
  <xs:element name="ComplementChoices"> 
    <xs:complexType> 
      <xs:sequence> 
        <xs:element name="Template" maxOccurs="unbounded" minOccurs="0"> 
          <xs:complexType> 
            <xs:sequence> 
              <xs:element name="tags" maxOccurs="1" minOccurs="1"> 
                <xs:complexType> 
                  <xs:sequence> 
                    <xs:element name="tag" type="xs:string" maxOccurs="unbounded" 
minOccurs="0" /> 
                  </xs:sequence> 
                </xs:complexType> 
              </xs:element> 
            </xs:sequence> 
            <xs:attribute name="type" use="required"> 
              <xs:simpleType> 
                <xs:restriction base="xs:string"> 
                  <xs:enumeration value="Goal" /> 
                  <xs:enumeration value="Strategy" /> 
                  <xs:enumeration value="Evidence" /> 
                  <xs:enumeration value="Undeveloped" /> 
                  <xs:enumeration value="Context" /> 
                  <xs:enumeration value="Monitor" /> 
                  <xs:enumeration value="Justification" /> 
                  <xs:enumeration value="System" /> 
                  <xs:enumeration value="Policy" /> 
                  <xs:enumeration value="Userdef001" /> 
                  <xs:enumeration value="Userdef002" /> 
                  <xs:enumeration value="Userdef003" /> 
                  <xs:enumeration value="Assumption " /> 
                  <xs:enumeration value="Contract " /> 
                  <xs:enumeration value="Module " /> 
                  <xs:enumeration value="All" /> 
                </xs:restriction> 
              </xs:simpleType> 
            </xs:attribute> 
            <xs:attribute name="path" type="xs:string" use="required" /> 
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            <xs:attribute name="name" type="xs:string" /> 
          </xs:complexType> 
        </xs:element> 
      </xs:sequence> 
    </xs:complexType> 
  </xs:element> 
</xs:schema> 
 

Table 23 Autocomplete Candidates Definition File: Schema Details 

No Name Type Description 

1 Complement Choices element Choices displayed in the autocomplete function. 
Template: Template 

2 Template element Templates displayed in the autocomplete 
function.  
Tags: List of tags. When tags are not specified, 
the node to be placed under a node will be 
determined by its type. 
@type: Type of node 
@path: Path of template 
@name: Name to be displayed in the context 

menu. 

3 tag element Tag 
 

Definition file is to be located as follows.  

D-Case Template Project/Complement.xml 

 

3 . 8 .  Setting the Order of Siblings 
The order of the siblings is set for the links that have Strategy as their source.  

The order of the siblings will be decided according to the x-coordinate. The node with the 
smallest x-coordinate will be the first one, and the rest of the order will be decided in ascending 
order. When there are multiple nodes with the same x-coordinate, the order will be decided 
according to their y-coordinate. Again, the node with the smallest y-coordinate will be the first 
one.  

 

Sibling Order Setting Flow 

Table 24 Sibling Order Setting Flow  

No. Procedure Behavior Details 
1 Select and right click a Strategy 

node in diagram. 
Context menu is displayed.   

2 Select”Set Sibling Order” from 
the context menu.  

The sibling order will be set for the links that 
have the selected node as their source.  
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3 . 9 .  Requirement setting 
D-Case Editor can set requirements of target system to Context Node. 

Goal node set the association with the requirement. 

 

 

Setting 
To show the requirement setting dialog, display context menu of Context node and choose “Set 
Requirements…” 

Requirement can use global parameters as format identifier. 

ex) 

{LoginUserCount} users can login at same time. 

 

The requirements users set appear the Desc Format String o Context by using the format 
identifier below.  

{Requirements} 

 

The list below shows the example of the display. 

Requriement1 

Requriement2 

     ・ 

     ・ 

     ・ 

Requriementn 

 

 

Make an association with goal. 
User can associate a Goal and requirement in Property dialog. 

 

confirmation 
select the below menu from menu bar. 

“Window”＞“Show View”>“Other…”>“D-Case Editor”>“Requirements” 
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3 . 1 0 .  Automatic Arrangement 
Positions of the nodes in the diagram that is being edited are automatically arranged.  

 

They are arranged in a tree according to their links. 

Nodes to be connected to the same source node are placed under the source node in the 
ascending sibling order starting 縦方向の場合は from the left、横方向の場合は上から. Sibling 
Order の指定が無いノードは、name プロパティのソート順に配置する。However, Context node and 
Justification are to be placed on the right of the source node 縦方向の場合は. 横方向の場合は
下に  

name プロパティのソート順は以下の通りとする。 

・	 数値が出てくるまでの文字列を辞書順で比較する。 

・	 上記で一致する場合は、さらに数値部分を大小比較する。 

 

Automatic Arrangement Flow 

Table 25 Automatic Arrangement Flow 

No. Procedure Behavior Details 
1 Select Diagram”>”Arrange”>”All” 

from the menu bar.  
Entire diagram is 
automatically arranged.  

デフォルトの整列方向は縦。方

向指定の整列を行った後は、そ

の方向で整列する。 
 

方向指定自動整列フロー  

No .  操作  アクション 詳細 

1 キャンバスの右クリックでコンテ

キストメニューを表示 
  

2.1 “Arrange”>”Vertical”を選択

する 
ダイアグラム全体を縦方向に自動

整列 

 

2.2 “Arrange”>”Hrizontal”を選択

する 
ダイアグラム全体を横方向に自動

整列 

 

表 1 方向指定自動整列フロー 
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4. Display Function 
4 . 1 .  Enlargement and Reduction 
There are four ways to enlarge or reduce the display of the graphic-object editing area.  

1. In the menu area:  
Select the editing window and click an item in the “Zoom” submenu in the “Diagram” menu.  
 

2. In the button area:  
Click an item in the magnification menu displayed in the button area.  
 

3. In the Palette area:  
Click the enlarge/reduce icon displayed in the upper part of the Palette area.  
 

4. In the graphic-object editing area:  
Right click the graphic-object editing area without selecting any node or link to display the 
context menu. Click an item in the “Zoom” submenu.  

 
 

To enlarge the selected node to fully fit the graphic-object editing area, select a node and click 
“Diagram>Zoom>Fit to Selection” in the Diagram menu.  

 

4 . 2 .  Changing the Part to Be Displayed 
“Outline View” shows the relation of the part that is being displayed to the entire diagram. The 
gray area in the “Outline View” is the part displayed in the graphic-object editing area.  

There are two ways to change the part displayed in the graphic-object editing area.  

1. In the graphic-object editing area:  

Move the scroll bar.  
2. In the “Outline View”:  

Drag and move the gray part. 
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4 . 3 .  Collapsing the Child Nodes 
All the child nodes can be displayed and hidden in the context menu of a selected node.  

- The child nodes of the node defined in D-Case Editor can be collapsed. This cannot be 
done with the general graphic objects.  

- Nodes with collapsed child nodes are made identifiable by changing the background color.  

- Switching from collapsed to expanded can only be done for the collapsed child nodes. 
Child nodes that are already displayed cannot be expanded.  

- The collapsed state of the child nodes is not saved. All the nodes and links will be 
displayed when the file is opened the next time.  

- All nodes are always displayed in the tree display of the outline view.  

- Collapsed nodes are not printed. Print area including the collapsed nodes can be specified.  

Child Nodes Collapsing Flow 

Table 27 Child Nodes Collapsing Flow 

No. Procedure Behavior Details 
1 Select 

“Show/Hide 
Children” from 
the context 
menu of node.  

The “Hide Children” and “Show 
Children” submenus are displayed 
when the “Show/Hide Children” item is 
selected from the menu.  

 

2 Select “Hide 
Children” from 
the cascaded 
submenu.  

The background color of the selected 
node is changed and all child nodes are 
hidden.  

 

 

 Child Nodes Displaying Flow 

Table 28 Child Nodes Displaying Flow 

No. Procedure Behavior Details 
1 Select 

“Show/Hide 
Children” from 
the context 
menu of node.  

The “Hide Children” and “Show 
Children” submenus are displayed 
when the “Show/Hide Children” item is 
selected from the menu. 

 

2 Select “Show 
Children” from 
the cascaded 
submenu.  

The background color of the selected 
node is changed to the default color 
(white), and all child nodes are 
displayed.  

When the background color is changed 
by the user, the information of the 
changed color will not be stored.  

 

* Hidden nodes can be selected in the Outline View. Hidden nodes cannot be selected by the 
“Select All" function.  
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Collapsing Child Nodes 

 

 

 

 

 

Displaying Child Nodes 

 

Figure 11 Collapsing Child Nodes  

Figure 12 Displaying Child Nodes  
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4 . 4 .  System Node 
The D-Case diagram to be referenced is set and displayed.  

Setting the Diagram to Be Referenced 
 

Reference Selection Flow  

Table 29 Reference Selection Flow 

No. Procedure Behavior Details 

1 Right click a given System node in 
Palette.  

Context menu is displayed.   

2 Select “Node Link” > “Select a 
Workspace...” from the context 
menu.  

Reference selection dialog is 
displayed.  

D-Case diagram in the 
workspace is displayed.  

3.1 Cancel the reference selection. Reference selection dialog is 
closed.  

 

3.2 Select a reference.  Reference selection dialog is 
closed. 
The selected reference is 
added to the System node.  

 

 

Displaying the Referenced Diagram 
 

Displaying Reference Flow 

Table 30 Displaying Reference Flow 

No. Procedure Behavior Details 

1 Right click a given System node in 
Palette. 

Context menu is displayed.  

2 Select “Node Link” > “Open 
with D-Case Editor” from the 
context menu.  

Diagram to be referenced is 
displayed. 

 

 

 

4 . 5 .  Open the Attachment 
User can open the workspace file and URL which is set to Attachment property. 

 

User can open the attachment with the default editor. 
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Open  t h e  a t t a c hmen t  w i t h  t h e  d e f a u l t  e d i t o r  

Table 31 flow in the default editor. 

No .  p rocedu re  behav io r  de ta i l s  

1 Right click a node Editor displays context menu  

2 Select 

“Attachment” -> 

“Open” from 

context menu 

Editor opens url with browser If 

attachment is url.  

Or Editor opens with default editor  

 

 

 

4 . 6 .  Displaying the Differences 
 

A file is compared with a specified file (model) and the differences between the two files are displayed.  

The following changes can be extracted for all links and nodes.  

- New additions – An ID in the current file does not exist in the original file.  
- Updates – The attribute of the node or link with the same ID is different in the original file and the 

current file.  
- Deletions – An ID in the original file does not exist in the current file.  

The extracted differences will be displayed as follows.  

In Diagram 

- New – The frame of node and the line of link become blue.  
- Updates - The frame of node and the line of link become red.  
- No changes - Black 

In Console 

The information that cannot be displayed in diagram will be displayed in console in text.  

- Results of the comparison of Arguments (output only when there are changes).  

Argument changed. 
 

- Information of the deleted nodes.  

Node: "Node name" [parents: "Parent node name"] deleted. 

- Information of the deleted links 

Link: "Link name" [source: "source node name"][target:"target node name"] deleted. 
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Displaying the Differences Flow 

Table 32 Displaying the Differences Flow 

No. Procedure Behavior Details 
1 Select ”D-Case”>”File”>”Compare 

To,,,” from the menu bar.  
Diagram file selection dialog 
is displayed.  

 

2 Select the diagram file to be 
compared with the current file.  

The differences are displayed 
in diagram and console.  

 

 

The source file and the target file can be switched while the differences are displayed in the 
diagram.  

Source-Target Switching Flow 

Table 33 Source-Target Switching Flow  

No. Procedure Behavior Details 

1 Display diagram a.    

2 Display the differences 
between diagram a and 
diagram b in diagram a.  

  

3 Select ”D-Case”>”File”>”Switch 
Source and Target” from the 
menu bar.  

Diagram b is displayed 
and the differences from 
diagram, extracted and 
displayed.  

 

 

 

4 . 7 .  f i n d  /  r e p l a ce  

User can find or replace the word from the all nodes in a diagram in a canvas. 

Select the below menu from menu bar, and show the Find/Replace dialog. 

“D-Case”＞“Find/Replace” 

If a node is selected, the finding starts there. Otherwise, the finding starts from top-left node. The 

direction of finding if forward only. 

The target of finding is Name と Desc. Replace manipulation replace Desc Format String. Parameters 

aren’t target of find/replace. 

If the word is found, Editor shows the Set Properties dialog, and selects the substring from Desc.  

 



D-Case Editor Functional Description 

 38 

 

 

4 . 8 .  conve r t i n g  n ode  t y pe .  

All node type can be converted to others. To convert a node type, select the target node and display 

the context menu and select  “Convert Node Type” > the type. 

 

Id and name are reassigned after conversion. Other properties are copied from the original node. 

 

If the original node has the properties that aren’t included the target node properties, the properties 

be added to the property called Userdef008with the format below. 

 

property_name =property_value 

 

If  Userdef008 already has a value, the string data above is concatenated the value. 
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5. Input/Output Function 
5 . 1 .  Conversion  
Converting GMF Model Information File to D-Case Model Information File  
GMF model information file can be converted to D-Case model information file.  
 
Flow of Conversion from GMF Model Information File to D-Case Model Information File  

Table 34 Flow of Conversion from GMF Model Information File to D-Case Model Information File 

No. Procedure Behavior Details 
1 Select “Convert D-Case File” > “From 

GMF to D-Case” from the “D-Case” 
menu of eclipse.  

“Convert Model to D-Case” 
wizard is displayed.  

Wizard is activated.  

2 Click the “Browse” button to display 
the file selection dialog. Specify the 
name of the GMF model information 
file to be converted and the name of 
the D-Case model information file to 
which it will be converted.  

The name of each file is 
displayed in the wizard.  

Enter the required 
information in the wizard.  

3 Click the “Finish” button.  File is converted and a D-Case 
model information file is 
created.  

D-Case model information 
file is created.  

 

Converting D-Case Model Information File to GMF Model Information File  
D-Case model information file can be converted to GMF model information file. 
 
* When the type of the attribute value is not correct, set the defined value.  

* When there is a decimal point in the value of an integer attribute, truncate the value to a whole 
number.  

Flow of Conversion of D-Case Model Information File to GMF Model Information File 

Table 35 Conversion of D-Case Model Information File to GMF Model Information File  

No. Procedure Behavior Details 
1 Select “Convert D-Case File” > “From 

D-Case to GMF” from the “D-Case” 
menu of eclipse. 

“Convert Model to GMF” wizard 
is displayed.  

Wizard is activated.  

2 Click the “Browse” button to display 
the file selection dialog. Specify the 
name of the D-Case model 
information file to be converted and 
the name of the GMF model 
information file to which it will be 
converted. 

The name of each file is 
displayed in the wizard. 

Enter the required 
information in the wizard.  

3 Click the “Finish” button.  File is converted and a GMF 
model information file is 
created.  

GMF model information file 
is created.  

 

Converting from D-Case model file to ARM file 
D-Case Editor can convert a D-Case model file to ARM file. 

 

 

C on ve r s i o n  f r om  D-Case  mode l  f i l e  t o  ARM  f i l e  
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Table 36 conversion from D-Case model file to ARM file 

No .  P rocedu re  Behav io r  Deta i l s  

1 Select eclipse “Convert D-Case File”

→“From D-Case to ARM” from top 

menu “D-Case” 

Convert Model to ARM wizard is 

displayed. 

 

2 Open the file chooser by Browse button 

and input the D-Case model filename 

and ARM filename. 

The wizard shows filenames.  

3 Press Finish button. D-Case Editor creates ARM file.  

 

Convert D-Case model file with XSLT 
D-Case Editor can use XSLT to convent D-Case model file. 

 

 

U s i n g  XSLT  t o  c o n v e r t  D -Case  mode l  f i l e  

Table 37 using XSLt to convert D-Case model file 

No .  P rocedu re  Behav io r  Deta i l s  

1 Select eclipse “Convert D-Case File”

→“XSL Transform From GMF Model” 

from top menu “D-Case” 

Submenu shows converters that 

are registered.  

 

2 Select a converter from submenu. The wizard opens.  

3 Open the file chooser by Browse button 

and input the D-Case model filename 

and target filename, 

The wizard shows filenames.  

4 Pres Finish button D-Case editor executes the 

conversion. 
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5 . 2 .  Automatically Generating a Diagram 
Generating a GMF Diagram File from a GMF Model Information File  

Handling of graphic items by D-Case Editor is not possible with GMF model information file alone. GMF 
diagram file is also necessary for a graphic use of D-Case Editor.  

To enable the handling of GMF model information file in D-Case Editor, a function for generating GMF 
diagram file from GMF model information file is provided.  

 
Flow of Generating GMF Diagram File from GMF Model Information File  

Table 38 Flow of Generating GMF Diagram File from GMF Model Information File 

No. Procedure Behavior Details 
1 Select the GMF model information 

file from which GMF diagram file is 
to be generated from the File list 
view of project Explorer.  

The color of the file name is 
inverted and the file becomes 
selected.  

File becomes selected. 

2 Select ”Initialize D-Case 
Diagram diagram file” from the 
context menu.  

Wizard is displayed.  Enter the required 
information in the wizard.  

3 Select a folder under which GMF 
diagram file is to be generated.  

Folder is selected and the 
default GMF diagram file name 
is set in Filename.  

Enter the required 
information in the wizard.  

4 Click the “Finish” button. The function is executed and 
GMF diagram file is generated. 

GMF diagram file is 
generated.  

 

 

5 . 3 .  Printing a Diagram  

The following operations regarding printing are available under the “File” menu.  

1. “Print Preview” item: Print preview  
2. “Print...” item : Print 
3. “Page Setup...” item : Print settings 

 

 

5 . 4 .  Crea t i n g  EPS  f i l e  
D-Case Editor can create EPS file from a diagram. 

Select a canvas or nodes, links, and choose ”File”>”Save As EPS File…” from the context menu. 

 

D-Case Editor uses the batchfile which executes Ghostscript to create EPS file.  

The batchfile is in the place below. 

 

At the workspace  

dcase/convertPdfToEps.bat
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6. Appendix 
 

6 . 1 .  Access Key of Menu 
Each menu can be called by typing the appropriate key(s) on the keyboard. The underlined 
character in the menu list below is allocated as the access key to each menu.  

 

Menu Bar 

Table 39 Menu Bar 

D-Case 

Convert File Type 

From GMF To D-Case Model 
From D-Case To GMF Model 

From GMF To ARM 
XSL Transform From GMF 
Model 

Find/Replace  

File 

Copy To... 
Rename... 
Compare To... 

Switch Source and Target 
 

Context Menu of Argument and Node  

Table 40 Context Menu of Argument and Node 

Parameters 

Configure Parameters... 
*exclude Argument   
Set Parameters... 
*exclude Argument  
Configure Global Parameters... 
*Argument only  
Set Global Parameters... 
*Argument only  

Set Requirements...   

Arrange 

Vertical 

*Argument のみ  

Horizontal 

*Argument のみ  

Select subtree 

*Argument を除く   

Add Child Create a New Node 

Goal 
Strategy 

Evidence 
Monitor 
Assumption 

Undeveloped 
Module 
Contract 

Context 
Justification 
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System 
Policy 

Userdef001 
Userdef002 
Userdef003 

Add a Template 
Dependent on the definition in 
Complement.xml. 

  

Convert Node Type 

Goal  
Strategy  
Evidence  

Monitor  
Assumption  
Undeveloped  

Module  
Contract  
Context  

Justification  
System  
Policy  

Userdef001  
Userdef002  
Userdef003  

Calculate the Score   

Attachment 
Select from Workspace  
Select from Web...  

Open  

Node Link Select from Workspace...  
Open with D-Case Editor  

Risk Analysis Open with Web Browser  

Show / Hide Children Show Children  
Hide Children  

DS-Bench 

Select Test Scenario 

※Strategy only  
Set Parameters... 

※Goal only  
Execute 

※Goal only  
Refresh 

※Goal only  
Set Sibling Order   
File Save As Eps File...  

 

Context Menu of Model Information File 

Table 41 Context Menu of Model Information File  

Initialize dcase_diagram 
diagram file   
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7. Limit 
7 . 1 .  Copying a diagram  
D-Case diagram consists of two files. If you copy a diagram, don’t use drag and drop , instead 
use the function described in 2.5 Copying a diagram. 
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